Ram Laxman Yadav bio photo

Ram Laxman Yadav

Ruby on Rails Developer

Email Twitter LinkedIn Github Stackoverflow

Recently I got an error while running the command sudo apt-get update. The error was Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/Release Unable to find expected entry 'main/binary-i386/Packages' in Release file I was not able to fix this issue because my system showing some broken pakeges are there. Here are details about this error:

Reason:

The reason behind this error is due to Google dropped support for 32-bit Chrome on Linux an error occurs when updating apt in 64-bit systems (with multi arch enabled).

Solution:

To solve this error we have to modify the sources.list file for Chrome

  • Open terminal and run command sudo nano /etc/apt/sources.list.d/google-chrome.list.
  • Now change the deb http://dl.google.com/linux/chrome/deb/ stable main line to deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main.
  • Enter Ctrl + X and type yes to save file.
  • Now run sudo apt-get update.

Enjoy!!!!